#!/bin/bash

# Slackware build script for pysolfc-extra-cardsets

# Written by B. Watson (urchlay@slackware.uk)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

# 20231217 bkw: updated for v2.2.
# 20230111 bkw: updated for v2.1.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=pysolfc-extra-cardsets
SRCNAM=PySolFC-Cardsets
VERSION=${VERSION:-2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG/usr/share/PySolFC $OUTPUT
cd $PKG/usr/share/PySolFC
tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2 --strip-components=1
tar xvf $CWD/pysolfc-cardsets-bknoll.tar.xz --strip-components=1

# Don't include cardsets that are already in the main pysolfc package.
# 20231217 bkw: matching and matching-xl moved to the main pkg in 2.20.0.
rm -rf \
    cardset-2000 \
    cardset-crystal-mahjongg \
    cardset-dashavatara-ganjifa \
    cardset-dashavatara-ganjifa-xl \
    cardset-dondorf \
    cardset-gnome-mahjongg-1 \
    cardset-hanafuda-200-years \
    cardset-hexadeck \
    cardset-louie-mantia-hanafuda \
    cardset-matching \
    cardset-matching-xl \
    cardset-matrix \
    cardset-mughal-ganjifa \
    cardset-mughal-ganjifa-xl \
    cardset-neo \
    cardset-neo-hex \
    cardset-neo-tarock \
    cardset-next-matrix \
    cardset-oxymoron \
    cardset-standard \
    cardset-tuxedo \
    cardset-uni-mahjongg \
    cardset-vienna-2k

chown -R root:root .

# No executables, all files should be 644 here.
find -L . -type d -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
          -type f -a \! -perm 644 -a -exec chmod 644 {} \+

# No docs, include our own README.
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE